Black smoke from Mercedes C200

I own a Mercedes-Benz C200 2010 model.It has 400,000KM and lately I noticed the following:

When i start the car, it works at around 800rpm.

When i press the acceleration pedal at N it "chokes" for a second and after it goes over 1000RPM it works.

Also when I stop at lights, or before I park there is some black smoke, not alot but enough that I can see it from my rear view mirror.

I cleaned the air filter and the air sensors, added diesel fuel system cleaner, but it hasn't fixed the problems. What do you suggest?


Asked on 18 May 2015 by assaf

Answered by Honest John
Most likely valve stem oil seals at this high 400,000k, figure. Possibly turbo bearing oil seal.
Similar questions
I had the emissions "fix" on my 2010 Audi A3 at the end of February and had nothing but problems since. Power has been altered dramatically and even to the point of cutting out on me a few times. I've...
A friend's 2007 Audi A6 2.0 TDI had a DPF removed and deleted, as well as an EGR shut. It also had a remap done. From test drive, the vehicle begun emitting excesses smoke when the engine was heated and...
I have a 2009 Honda CR-V CDT-i with 60,000 miles on the clock. Under heavy acceleration there is black smoke out the exhaust - a fair amount. We have done 5000 miles in the five months since buying it...
Related models
A big improvement on the previous C-Class. Feels well built and robust. Very comfortable and refined. High quality ride. Good CDI diesels.
 

Ask Honest John

Value my car