Limping Vectra

Bought this car for my wife about 6mths ago and when we first got it every month or so the spanner light comes on and it goes into limp mode, once you switch engine off and back on again it was fine for another month or so but now it is getting worse, happening 2 or 3 times a day, it seems to happen when accelerating hardish, ie up a hill or slight incline.

Can anyone give me an idea of what it may be and what sort of cost I might be looking at, it has done 94,000 miles.

Asked on 31 August 2011 by ern2011

Answered by Honest John
Might be a gummed up throttle. Worth adding a 'fuel system cleaner' to the petrol, then fill up with Shell V-Power petrol. That's the cheapest first attempt at fixing it.
Similar questions
I have a petrol 2005 Renault Laguna 2.0, the engine runs like a dream but sometimes when you are driving along there will huge loss of power for a few miles meaning that I have to drop it down to lower...
I have been out to start my car. It started fine, but when I went to rev the car there was nothing coming from the accelerator. I tried it a few times and now it's working again. Just wondering if anyone...
I recently changed the intercooler on my 2010 Jaguar XF and now I'm getting an intermittent warning message which reads 'water in fuel, consult handbook.' How do I get rid of this message?
Related models
Far better than previous Vectra. Now with decent handling and an excellent ride. Plenty of safety kit. Roomy in the front. Big boot. Good looks.
 

Value my car