Vauxhall Insignia Sports Tourer - Thermostat Faulty? - Deryck Tintagel

I have the 1.8 petrol Insignia and have had the "Service Vehicle Soon" warning and the cooling fans constantly running. A quick Google suggested the thermostat may be the culprit.

My local garage suggested a fan control ECU needed replacing but I was not sure if their diagnostic kit could tell the differnce between the thermostat or ECU fault.

I am considering taking the car to Vauxhall for diagniostic checks but in the meantime I checked the resistance across the terminals on the thermostat. I measured 230kOhms which seems high but I am not 100% sure what the connections are - possibly a heating element.

Does anyone know what the resistance should read?

TIA

Vauxhall Insignia Sports Tourer - Thermostat Faulty? - Railroad.

I assume you mean coolant temperature sensor, not thermostat which is a completely different thing. Expect a sensor resistance of around 3kohms when the engine is cold, falling to about 200ohms when it's hot.

Vauxhall Insignia Sports Tourer - Thermostat Faulty? - Deryck Tintagel

I assume you mean coolant temperature sensor, not thermostat which is a completely different thing. Expect a sensor resistance of around 3kohms when the engine is cold, falling to about 200ohms when it's hot.

No, definitely the thermostat. Looking at the engine there is the coolant sensor just above the thermostat and that is showing the correct temperature on the dash - it sits quite happily at 90°C until the car is at standstill for some time and it will rise slightly.

The thermostat has an electrical connection, which I understand is a heating element, but I would not swear to it. I would expect something a lot less than the 230kOhms I have measured if it is an element

Vauxhall Insignia Sports Tourer - Thermostat Faulty? - elekie&a/c doctor

Heating element in the stat housing should be around 15 ohms. There is also a second coolant temp sensor in the lower rad hose. Is there water flow across the rad?

Vauxhall Insignia Sports Tourer - Thermostat Faulty? - Deryck Tintagel

Heating element in the stat housing should be around 15 ohms. There is also a second coolant temp sensor in the lower rad hose. Is there water flow across the rad?

elekie&a/c doctor thanks for the reply.

15 Ohms sounds more like what I expected, so it looks like a faulty stat.

I would have to check the water flow across the rad. Would there be any issue as the engine temperature looks OK?

Is there anything I need to check on the other coolant temperature sensor? Which one provides the information to the dash temperature gauge do you know?

Thanks

Edited by Deryck Tintagel on 22/02/2017 at 09:57

Vauxhall Insignia Sports Tourer - Thermostat Faulty? - jc2

Disconnect each sensor in turn and look at the gauge.

Vauxhall Insignia Sports Tourer - Thermostat Faulty? - Deryck Tintagel

Yes, both hoses are hot so it looks like water is passing through

 

Ask Honest John

Value my car