Peugeot 406 - intermittent non start and run on - flowerloverman

Hi, i would like to request some advice for my car , it is a 2002 406 2.0 hdi 110, a couple of times in the last 2 weeks when i have come to start it in the morning it turns over fast but the engine doesnt fire then after a few attempt it eventually starts , i`m not sure if it a coincidence but the radio had to put on standby before it would fire , any how it can then be ok for a couple of days then it will struggle again , when it does finally start the idle is a little lumpy similar to if there was a glow plug down and then it will settle , yesterday it did the non start thing and eventually fired up but when it came to turn the car off the engine kept running for about 4 seconds then turned off , ive been out today and there hasnt been any problem , started first time and turned off fine , there are no power issues , when it is running it is perfect , its just the ocassional difficult starting and the run on after the key has been turned off , i am going to try and get it scanned this next week but as the engine light hasnt been on i`m not sure if anything will be found , i hope someone can assist and advise , thanks in advance , simon

Peugeot 406 - intermittent non start and run on - elekie&a/c doctor

These old soldiers are fairly reliable,more so than the current breed of technical nightmares.However,one weak point on these is the in-tank electric lift pump.When it is a non start,lift the back seat cushion and see if you can hear the pump prime when ignition is first switched on.Doubt if a diagnostic scan will prove beneficial.

Peugeot 406 - intermittent non start and run on - flowerloverman

Hi , thanks for your reply , I have read about the lift pump and will check in the morning , also any ideas on the brief run on upon turning the key off or would the lift pump be connected in some way , thanks in advance , simon

Peugeot 406 - intermittent non start and run on - Peter.N.

Run on is often caused by the pressure regulator on the HP pump but check the in tank pump first as suggested.

Peugeot 406 - intermittent non start and run on - flowerloverman

Thanks peter , ill check the in tank pump , the car struggled to start at the petrol station today less than 2 minutes from stopping it , i have now worked out that if it has an episode of not being able to start , when it comes to shutting off the engine runs on , strange problem to be honest , would the in tank pump cause this sort of scenario or would this definitly be the regulator , its becoming a pain now as i have to be a work for 5 in the morning and work 20 miles away , especially when it doesnt seem to want to start , thanks in advance , simon

Peugeot 406 - intermittent non start and run on - elekie&a/c doctor

Don't think the in tank pump would cause this problem.But as Mr PN says ,a faulty fuel inlet reg could cause both issues.On a common rail diesel,the fuel is regulated on both the suction side (inlet to the pump)and the outlet(high pressure)

Peugeot 406 - intermittent non start and run on - Gibbo_Wirral

Sounds like it could be the diesel temperature sensor.

Google "Peugeot Planet Diagnostic Map" for someone local to you with the diagnostic gear.

It should pick up any anomalies and can provide comprehensive sensor data on all aspects of the car while starting and running.

Peugeot 406 - intermittent non start and run on - flowerloverman

Hi all , thought i would post an update , last week i had the car in with a peugeot / citroen specialist and gave him the symptoms , 3 days later and 300 quid lighter i had the car back , he said he had done diagnostics on it and checked the live data and all looked normal but he couldnt find anything wrong , he noted that the engine was turning over slower so he changed the starter motor , any how for 4 days the car worked fine until yesterday morning , it struggled to start , was cranking over fine just wouldnt fire and took a few minutes to start it , got to work and it ran on again for a few seconds , but wouldnt restart , i had the rac out to me last night and he put his diagnostic scanner on it and it came up with 3 faults , maf sensor , cooling fan fault and although these 2 wouldnt cause a non start , the third however he said would , P0215 - injection system relay , i cant find much information on this , maybe someone knows what i am looking for , also once the engine is hot and idling it seems to drop slightly and rev back up so it stays at idle speed , i am getting to the end of my tether and due to last weeks waste of time and money i am now short on funds , i hope someone can help me , thanks in advance , simon

flowerloverman Newbie Posts: 5 Joined: Tue Nov 11, 2014 1:54 am





Top
 

Ask Honest John

Value my car