Citroen Xsara Picasso 2.0 HDI 2003 model - engine temperature - oregon

Hi i have recently had problems with the cooling system whereby after a longish run the temp gauge will jump from normal too high position in the red the computer emits a stop engine temp too high message, the cooling fans are operating after letting the cooling fans stop and i check the coolant there is no loss whatsoever the system is not pressurising at all and the radiator is coldish all over as is the engine block the only hot area is the head wher the sender is located .. I have replaced the sensor and the thermostat and the radiator bled the system as appropriate with no success it just seems there is no circulation, and my thoughts are the water pump what can u suggest,, thanks John

Citroen Xsara Picasso 2.0 HDI 2003 model - engine temperature - Peter.N.

The only other thing that springs to mind is the water pump, I don't know about your particular car but some pumps suffer with the impeller coming loose on the shaft. Does your heater work OK? That's usually a good indicator as to whether the coolant is circulating properly. They has been a spate of faulty new thermostats lately, if you still have the old one try boiling it in a pan of water and see if it opens, likewise with the new one.

Citroen Xsara Picasso 2.0 HDI 2003 model - engine temperature - big_G

hi, it looks like problem with temp sensor or with wiring system that i can check as well. ;)

Citroen Xsara Picasso 2.0 HDI 2003 model - engine temperature - chance113

Hi, Did you find out what was the problem ?, I am having the same problem, get the car out in the morning drive a 1/4 of a mile then the temp engine warning keeps buzzing, once its showing one pip on the temp gauge everything is ok, another thing if I leave it parked on a hot day for a couple of hours then start the car the fan come on right away, I am going to try a new thermostat and sensor. Thanks Steve

 

Value my car