1994 1.4 Loss of power/sports mode light on M Reg - Saz22
I recently bought a 1994 auto Corsa Merit, but have had several problems with a cold start. The engine was cutting out when idling, or not starting at all. The computer came up with error code 35, no idle speed control. I have now had the following parts replaced by 2 seperate garages:

Idle Control Valve
Oil seal replaced
Spark plugs changed
Oil and oil filter changed (twice!)
Radiator fan switch replaced (twice!)
Cylinder head gasket replaced (although I was only given an invoice for £5.28 for the part so not sure what work they actually did!)
Thermostat kit replaced - was invoiced but not sure whether this was actually done...

After I had all this done (some included in service) the car was starting better, but engine light was coming on/going off at random. Then the sports mode light started coming on/going off at random. I took the car in and was told that the same error code was coming up. The garage readjusted the ignition timer to 10 degrees, and this then cleared the code.

However, after driving away from the garage with no problems, the sports mode light now comes on for a short while when the engine is turned on, then goes off (this was flickering intermittently before). The car doesn't have power until it warms up, and hesitates on acceleration.

The last garage told me he didn't think it was a gearbox fault, but I'm at my wits end as to what else I can do!

Any suggestions much appreciated!!



1994 1.4 Loss of power/sports mode light on M Reg - Dynamic Dave
The last garage told me he didn't think it was a gearbox fault


They're wrong.

See my reply from only yesterday regarding the same fault.

www.honestjohn.co.uk/forum/post/index.htm?v=e&t=72...7

1994 1.4 Loss of power/sports mode light on M Reg - Saz22
I think I'm going to have to get the gear selector switch replaced. There are no more error codes showing and he said the gearbox oil looks fine. Any ideas how much work is involved? I know a mechanic so will try and get the part second hand and get them to do the work, but no idea how much this is going to cost!
1994 1.4 Loss of power/sports mode light on M Reg - Dynamic Dave
I'm surprised there isn't an error code.

The selector switch can be stripped down and cleaned, if that is the problem? Guesswork can be an expensive hobby if you start changing parts willy nilly without knowing the real reason for the fault. And who's to say the 2nd hand switch won't also be faulty!

I do have a link on my other PC that shows to to strip and clean the selector switch; that is if its the same one that's fitted to Cavalier gearboxes.

Edited by Dynamic Dave on 04/03/2009 at 10:15

1994 1.4 Loss of power/sports mode light on M Reg - Dynamic Dave
I do have a link on my other PC


Found it via another forum I previously posted it on.

sirbendy.jemjabella.co.uk/autoswitch/

1994 1.4 Loss of power/sports mode light on M Reg - Saz22
Thanks, definitely worth a try. Again, the problem is sporadic, some days it's fine and others terrible, so willing to give it a try.
1994 1.4 Loss of power/sports mode light on M Reg - clarehcluck
I am having the same problem. On starting the car, my sports mode light is flashing and is almost powerless in pulling away. Is there any way 2 control this untill i can get it fixed, and did it work whe u tried what you did??
1994 1.4 Loss of power/sports mode light on M Reg - Dynamic Dave
On starting the car my sports mode light is flashing and is almost powerless in pulling away.


The flashing light is telling you the car has gone into limp home mode.
Is there any way 2 control this untill i can get it fixed and did it work whe u tried what you did??


The only way would be to use the auto box in manual mode - ie, select 1, 2, 3, etc instead of the box doing the work for you.

Ultimately though you need the fault code(s) reading out, sooner rather than later.

ps, donning my moderators hat for a moment. Can you use proper words and not 'txt' talk please - thanks. DD.

 

Value my car