Peugeot 207 - High Speed Only - Indicator not working!!! - pauld123

Hi, I have a real puzzle. Going down the motorway my rear indicator started flashing double time, I have checked and definitely the back one is not working. But when I slow down it starts working again. I have done a few test runs and have narrowed it down to something I just don't understand.

If the car is doing over 50mph the rear indicator does not work. But slowing down to less than 50mph it kicks back in and works normally.

Does anyone have any possible explanation, it is wrecking my head as i have never seen anything like this?

Peugeot 207 - High Speed Only - Indicator not working!!! - Peter.N.

Sounds strange, I would suggest either a bad earth somewhere or a varying 12 volt supply. Try connecting a voltmeter to the cigar lighter so you can read it when you are driving and see if the voltage varies, it should read around 14.4 volts all the while the engine is running.

Peugeot 207 - High Speed Only - Indicator not working!!! - Gibbo_Wirral

207 you say? Rear cluster wiring fault - the earth wire isn't beefy enough and burns out.

Common fault on 207 and 407, dead easy to fix.

Peugeot 207 - High Speed Only - Indicator not working!!! - elekie&a/c doctor
As above,remove the light cluster and closely inspect the multi pin connector.Very likely one pin has overheated.
Peugeot 207 - High Speed Only - Indicator not working!!! - pauld123

Thanks very much.

I was surprised by the intermittant nature. It's good to now know what to look at.

I also noticed that when the indicator is flashing double time, if I press the brakes and slow down about five miles per hour then then indicator returns to normal.

Does Breaking somehow dissipate the static from the car and allow the Earth to work easier?

Peugeot 207 - High Speed Only - Indicator not working!!! - Gibbo_Wirral

No, the current will be going to the rear brake light as well as the indicator, so sharing the load and reducing the current in the return earth wire.

Peugeot 207 - High Speed Only - Indicator not working!!! - Gibbo_Wirral

This is the guide you'll need:

www.407owners.com/docs/rearlightbulbsold.pdf

 

Ask Honest John

Value my car