Numerous warning lights and problems with a Ford C-MAX

We love our car but we have had an unresolved engine management issue with it since the middle of 2012. The engine management warning light came on (on Friday 13 July!) and immediately the car lost all power with a system failure message.

The car was eventually taken to our local Ford dealer when our usual garage was unable to even start the car. Ford were initially unable to diagnose the problem as their diagnostic equipment kept on throwing up several fault codes including instrument cluster failure. The pcm and wiring cluster was checked cleaned and car reassembled and all seemed OK and nothing was replaced.

This cost us £489.41 in labour. The car then started misbehaving a month later (losing power, speedo falling to zero and recovering, engine warning light on) and then they replaced the accelerator pedal sensor (FOC) after much complaining.

Now at the end of the year, the problem has reappeared, and this happened after I drove in torrential rain and through several flooded sections of road. The warning messages we are getting include, 'Limited Speed Mode, 'Steering Assist Failure', the Speedo fails occasionally and the car will lose power momentarily when we are decelerating which is really scary, but then picks up again. Ford have in all fairness tried to sort the problem out so no real complaints there. Do you have any suggestions?

Asked on 2 January 2013 by IMMO

Answered by Alan Ross
Well given what you have said, ref the "steering assist failure" we would suggest that you may have got water into the main multiplug on the EHPAS pump.
This should be checked out asap.
Similar questions
I have a 2009 Ford Mondeo TDCi X Sport that's done 95,000 miles. I was driving at appox 40mph when I suddenly lost my power steering. The engine management light came on and there was a rasping noise from...
I have just bought a Peugeot 206 automatic which is having problems getting up hills, and the icicle light and the sports light keep flashing. Any ideal what the problem is?
I've just bought a Renault Megane 1.6 petrol. When I start the engine, it starts but loses power at first. It needs a bit of accelerating to keep the engine running. I have changed the spark plugs already,...
Related models
Best entry and egress of any car anywhere. Excellent front seat comfort.
 

Value my car