Horn not working - corblimeyguvnar
A Merry Christmas to you all.

Pugs horn has packed up, checked fuse, all ok, actual horn still works (can check this by doing remote plip and it toots at me lovely)
But, press the steering wheel and not a peep, any ideas what it could be, and more importantly any ideas how much its going to cost me, MOT due in a month so have to get it done asap.
Cheers all

CBG
--
Drink Lager, Talk Piffle,
Horn not working - Screwloose
cbg

Have you had an airbag light coming on? It really needs the BSI code-reading to see where the CAN signal stops; but the Comms 2000 module behind the wheel would be my first suspicion.
Horn not working - corblimeyguvnar
Airbag light not been coming on as far as I am aware, but the comms2000 hasnt been well since I got the car, indicator stalk wise.
Have had a quick Google for the fault and it looks like its not uncommon (should have done that before posting in the BR really), will it be a new Comms, or as suggested on some other forums its someting to do with a bad connection, or is that just wishfull thinking.
Cheers
CBG
--
Drink Lager, Talk Piffle,
Horn not working - Screwloose
CBG

It's never a good idea to be too certain until it's plugged-in; but I would not be at all surprised if you end up fitting a new Comms module. If the indicator stalk is playing-up, you'll need to fit one soon anyway.

[And then another... and another.... and another.... until you get a new one that isn't faulty!!! If you have to fit eight in succession to get all it's functions working properly; then you hold the new record!]
Horn not working - corblimeyguvnar
Cheers Screwloose, suppose I have been lucky as the indicators have been a tad eccentric for 3 years now, was wondering when they or something realted would go belly up (didnt realise the horn was part of the gismo though).
So thats about £150 for the part plus another £50 or so labour, if my memory serves me correctly?

Why am I beginning to think that 2008 isnt going to be a happy motoring year in the Guvnar household :-(

Oh and just to rub it in C15 wouldnt start this morning, think I need a new battery, darn it.

Happy days

CBG
--
Drink Lager, Talk Piffle,
Horn not working - Screwloose
CBG

The horn [and both airbag circuits] are connected through natty flex-Nylon strips to the Comms ECU. It then generates a CAN signal that is filtered-out by the BSI [body control] module which then activates the horn, using it's internal relays.

As the horn works on the fob; then we know that the BSI is able to sound it. So the possibilities that exist are:-

The horn contact closing isn't reaching the Comms 2000;
The Comms isn't reacting and generating a clean "sound horn" code into the CAN;
The BSI isn't reading that code because it's getting corrupted by a wiring fault;
The BSI is reading the code, but not acting upon it;
Something else - because it's French and not in the mood....
Horn not working - corblimeyguvnar
Nothing complicated then :-)
So looks like we are probably going to have to get a new comms whatsit, OK, I'll start saving now, shame the MOT is due soon or I could drag it out a bit.

Anyway, thanks SL, as always excellent assistance.

Have a spiffing Christmas.

CBG
--
Drink Lager, Talk Piffle,

Edited by corblimeyguvnar{P} on 24/12/2007 at 17:16

Horn not working - elekie&a/c doctor
Intermittant or non working horn is a common fault on these and can be caused by a bad connection behind the airbag.There is a wiring terminal riveted to the steering wheel that becomes loose with a resulting poor contact.hth
Horn not working - corblimeyguvnar
Please Mr Christmas, let it be a simple dodgy connection, pleeaase!!
--
Drink Lager, Talk Piffle,
Horn not working - jayvee
I have a similar fault on my 307, it works sometimes if you depress the centre of the steering wheel, how easy is it to get to the connections without the airbag going off?
Horn not working - corblimeyguvnar
Ooooh, got all excited earlier as the horn started working again, all 3 spokes and in the centre, then later just the centre, now it doesnt work at all, again.
Hopefully this means it is the contact problem.
The Pug swines going in for MOT Friday and they are going to have a look at the horn then (Local Independant not main dealer), fingers n toes crossed.

CBG
Horn not working - corblimeyguvnar
By some strange quirk of fate she passed the MOT (maybe I was frettin a tad too much), I did tell the tester that there was an intermittent fault with the horn and could he have a look.
When I picked the motor up and asked what was wrong with the horn his answer was 'it worked when I tested it, it works now', he went on to say that it would take a while to remove everything that was required to have a proper look so maybe I should leave it for now as it was working, if it stops again bring it back.
Suppose thats fair enough, its still working. No doubt someone will disagree though.

CBG
Horn not working - monkeyboy307
Had the same problem just before christmas, mine was due to the bad contact, really quite easy to fix.
Remove battery connection 20 mins before starting work to allow all power to dissipate from airbag circuit.
On the back of the steering wheel either side of the horizontal spokes there is a small hole (3-4mm) insert a suitable poking device, I used a teminal screwdriver, this will release the two spring clips retaining the airbag assembly. The first one went easily, the second needed quite a bit of pressure.
Now the airbag is released you will find a plug and socket at the back which can be disconnected.
At around the 11 o'clock position you will see a pair of black cables attatched to a single crimp pushed into the metal body of the steering wheel, this is the bad connection. Now you must decide how to fix it, I spoke to a mechanic at the local main dealer who told me they normally fit a self tapping screw into the steering wheel and recrimp the wires, personally I opted for polishing the crimp and steering wheel with wire wool, not too happy drilling holes in the wheel myself.
Thats it, reconnect the airbag, press back into place and reconnect the battery.
Four months on now and still working like a dream.
Hope this is of help.
Rob.
Horn not working - corblimeyguvnar
I'll give that a go, cheers for the info, fingers crossed.
It has been working on and off, just have to give the wheel a wack every now n again :-)

CBG
Horn not working - SatCure
Thanks for the information. This job turned out to be really easy! I've put photos of the job here:
www.glodark.com/peugeot-307-horn.htm
 

Ask Honest John

Value my car