02, 2.0 petrol EWL flashing & engine cutting out - cdn
I have had the car for approx 4 months bought privately and have had no problems until now apart from high fuel consumption. Its doing around 250miles to the tank. Also, I was driving yesterday and the engine warning light came on and was flashing for a couple of mins. the power steering then cut out swiftly followed by the engine. There is a smell of petrol occasionally on the drivers side (rear).
Last point...after starting up and driving a short distance (i.e. for a paper) and turning off the engine, when it comes to starting again there is delay of a few seconds.
any help would be appreciated.

SLT

Edited by Pugugly {P} on 11/11/2007 at 21:54

02, 2.0 petrol EWL flashing & engine cutting out - Screwloose
cdn

It cut out - then what happened?
02, 2.0 petrol EWL flashing & engine cutting out - cdn
I started the engine and the ewl didnt come back on. have since taken the car to ford and they have reset the computer and updated the model. they say this should solve my problems but will find out whether it does over the next few weeks
02, 2.0 petrol EWL flashing & engine cutting out - TurboD
re high fuel consumption, I have an 05 2l.estate. If you 'just go for a paper' it won't be doing too many to the gallon- but your 19 is very bad. Round town expect 25-30= 325 mile to 390.
on motorway runs at reasonable speeds I get up to 450.
Tank holds 13 gallons.
Mine been perfect so far - runs smooth and silent. crossedfingers
02, 2.0 petrol EWL flashing & engine cutting out - cdn
yeah i understand that it wont do many miles just going for a paper...that was just an example of when it wouldnt start properly.
thanks for everyones comments. all seems to be well so far after taking it to ford so fingers crossed.
 

Ask Honest John

Value my car