Is your local garage worth shouting about? We want to hear about it. | No thanks
Renault Scenic (2003 - 2009) - 04 1.9 dCi - loss of power and "check injection"  
04 1.9 dCi - loss of power and "check injection" - DP
SWMBO has just called. The Scenic's lost power and has flagged up "Check Injection". Seems to be running fine, just completely gutless. Not smoking, no funny noises.

On its way to the dealer now. Any ideas what we're looking at?

Cheers
DP

Edited by DP on 12/05/2008 at 12:12

Tags: technical issues family cars consumer rights

04 1.9 dCi - loss of power and "check injection" - Screwloose
DP

Gone into limp-home? The message is generic - code read needed.
04 1.9 dCi - loss of power and "check injection" - DP
She's just called. It made it there OK (about 10 miles) just at a very sedate pace.

They're going to squeeze it in this afternoon for us.

Will let you know the outcome.

cheers
DP
04 1.9 dCi - loss of power and - DP
It had a low boost code, and on further investigation they found a split in one of the turbo hoses.
Hose replaced, code reset, road tested and fine. £80 all in.

Cheers
DP

Edited by DP on 12/05/2008 at 15:53

04 1.9 dCi - loss of power and - injection doc
well congratulations, a happy ending & obviously a good garage
Doc
04 1.9 dCi - loss of power and - DP
Thanks Doc. This is the local Renault agent whose praises I've sung on here before. They've always looked after us well, and this is another example.

Of course I'll relax TOTALLY once we pick it up in the morning. ;-)

Cheers
DP
04 1.9 dCi - loss of power and - DP
Yup, SWMBO collected it this morning and it's back to its old self. She said it feels really perky compared to recently, so I guess there might have been a slight leak for a while.

They also replaced a popped brake light bulb (I noticed this on Sunday and hadn't got round to it) FOC.

Happy.

Thanks for the responses Screwloose and Doc.

Cheers
DP

Edited by DP on 13/05/2008 at 11:14

04 1.9 dCi - loss of power and - aahbarnes
Any idea which hose was split? I have the same car and would like to check mine.
04 1.9 dCi - loss of power and - DP
It was a wastegate hose I think. I have the technician's report on the invoice - will post it verbatim when I get home tonight.

Cheers
DP
04 1.9 dCi - loss of power and - DP
As promised:

"Carried out a full system test using CLIP. Traced a fault to the turbo pressure regulation circuit. Carried out the corrective service checks and found the vacuum pipe to the turbo wastegate split. Replaced, reset system, N/F/F"

Don't have a part number unfortunately.

Car hasn't skipped a beat since.

Hope this helps.

Cheers
DP

Edited by DP on 19/05/2008 at 18:55

04 1.9 dCi - loss of power and - aahbarnes
Always wondered what this CLIP thing is - I suppose it is their diagnostic computer.

Thanks for your help, will check mine!
04 1.9 dCi - loss of power and - socco
This warningnmessage has just flashed up. Picked the car up 5 days ago and it seems very sluggish. The message has gone off now but have booked it in to be looked at anyway. Renault dealer mentioned plugs but I will let them know about this useful info. Anyone know why the warning would have gone off?
04 1.9 dCi - loss of power and - DP
If it's glowplugs, the message will appear after starting from cold. If you let the engine warm, pull over, switch off and restart, the message will disappear.

When mine went, the engine ran fine, so if it feels sluggish you may have another problem. Bear in mind, as Screwloose says, 'check injection' is a generic "There's something wrong with me" message. It could be any number of things causing it.

If you've ever changed a set of spark plugs, you change glowplugs on this engine. Remove each one, test it by connecting it to the battery, and refit/replace as appropriate. The supply wire is just a push fit with no stupid little 8mm nut to lose - they even put a plastic pull handle on the terminal - and access is very straightforward once you pull off the plastic engine cover.

I had all four out, tested, and refitted, and the engine running again in 30 mins. Far easier than on any other diesel car I've owned.

Cheers
DP

Edited by DP on 26/06/2008 at 09:47

04 1.9 dCi - loss of power and - socco
The car has come back after a day at renault dealer with a new lease of life. They said a hose had come loose and had re-attached. Its like a different car and is now running like a dream. Thanks for the comment. I will be sure to share any future experience of this car.
04 1.9 dCi - loss of power and - adam_tomo
hi my car is doing exact what yours was i have a megane 1.9dci (130) 2005 and i have changes two of the faulty glow plugs, but now from cold start (check injection) and service light has gone off :-) but no on way back from blackpool today going 70mph came on again, sluggish, no power car running fine pulled over swich on and off service light gone off..... 70mph came back on after a few start and stops got home so i wonder if my turbo hose has come loose aswel???? i rang renault £82 just to see whats up on computer :-O is there anyway you no how to check this hose yourself? i would be very happy if you or anyone else no's.

thank you

Adam

Join the discussion

Reader Offers and Prizes

Latest News & Road Tests

Buying Advice

Honest John's Newsletter

Connect with Honest John

Facebook YouTube