Peugeot 206 hatchback (1998 - 2006) - 2003 1.4 HDI cuts out after starting  
2003 1.4 HDI cuts out after starting - Norman77
Car is a 2003 (03) Peugeot 206 1.4 HDI van

Car has just had 4 new injectors/clutch/gearbox at 70k miles

It cuts out usually when cold, slowing for a corner or junction.

It wont restart for half an hour and then idles perfectly.

Any ideas. Diagnostics say injector fault but not much else.

Could it be the high pressure pump at fault?

Cheers.

Edited by Dynamic Dave on 03/01/2008 at 21:23

Tags: technical issues unexplained noises maintenance and servicing automatics

2003 Peugeot 206 1.4 HDI cuts out after starting - Screwloose

Who on earth fitted four new injectors to an HDi? Whose ark are they out of?

What was the exact fault code? HDis are very tricky things to diagnose accurately and very expensive to get it wrong on.
2003 Peugeot 206 1.4 HDI cuts out after starting - Norman77
Its the work van.

The company are trying to save a few quid by taking it to the local comedy garage who really don't have a clue.

I think it was over £800 just for the injectors alone.

Peugeot main dealer is probably the best bet, but some people will not listen.
2003 Peugeot 206 1.4 HDI cuts out after starting - Screwloose

Those must've been cheap re-cons; new ones are nearer £2000. As you say - not a clue.

See if you can get that code - there isn't one for injectors [plural] but there are quite a few [of 3,000] that cover precise faults with individual ones.

It could well be a failing high-pressure pump [amonst many other things] which will mean that those "new" injectors are now frag-contaminated and scrap.

Precise rail-pressure readings via live-data [can they even do that] is the only way to tell.

Join the discussion

Buying Advice

Honest John's Newsletter

Connect with Honest John

Facebook YouTube