Ford Focus 1.6 TDDi V Reg - Flashing glow plug light and loss of power - dan_tddi

Hi all,

I've been doing a bit of reading on the forums and would like to pose my situation to ask for advice.

I have a Ford Focus TDDi 1.6 V reg which I have owned for the past couple of years. To be honest up to now it's been a pretty good car and quite reliable.

I drove from Oxford to London last week and while I was in London (at Hanger Lane gyratory of all places!) I suddenly lost all power to my car and the coil light started to flash. The car seemed like it was just ticking over and I managed to drive the car at a snails pace and pull over. I turned the car on and then off again and everything was fine for the rest of my journey. I then travelled from London back to Hull last Sunday with no problems at all.

On Monday morning this week the problem happened about 6 times while I was on my way into work, the same thing everytime, losing power, flashing light, pulling over and switching off and back on again. Everything was fine for a few minutes then it happened again.

I took my car into the garage and after some trouble with the machine, managed to hook a computer up to read the error codes (at a cost of £35 + VAT).

The garage has just rung me and said that the stored codes relate to:

1. EGR valve
2. Cylinder head temperature (reading 280 degrees C, but actual temperature is 100 degrees C).

Are these problems related?

The garage has quoted me £85 + VAT for the EGR valve and £80 + VAT to resolve the cylinder head temperature fault. They have said that since the computer is pointing to these faults, fixing these is the most logical place to start.

Having looked through the forums I was hoping it would only be my accelerator pedal and potentiometer (my nearest second hand place has one in for £25) but apparently a pedal fault isn't showing up.

Any advice would be very much well received.

Cheers

Dan

Ford Focus 1.6 TDDi V Reg - Flashing glow plug light and loss of power - Peter D

'a pedal fault isn't showing up.' I assume you came up with that theory. Does the garage not tell you what part is required to " resolve the cylinder head temperature fault.". Regards Peter

Ford Focus 1.6 TDDi V Reg - Flashing glow plug light and loss of power - dan_tddi

Hi Peter

The garage didn't mention anything about a pedal fault no.

The garage has only quoted me £80 + VAT to fix the cylinder head fault.

I'm tempted to go and pick it up and try cleaning the EGR valve myself and then see what happens....

Ford Focus 1.6 TDDi V Reg - Flashing glow plug light and loss of power - dan_tddi

Just spoke to the guy who took the tests. The sensor is a secondary problem really and they could be related.

I'm going to try and clean the EGR valve. I have been told that this is quite a lot of work and means taking off the inlet manifold? The guy I spoke to suggested that the inlet manifold and EGR valve are replaced. He reckons it's the early signs of an EGR failure and that it's sticking open occasionally.

I'm a bit of a novice when it comes to cars but have done bits and pieces in the past, pads, discs, alternator etc.. So hopefully it isn't too big a job??

Ford Focus 1.6 TDDi V Reg - Flashing glow plug light and loss of power - dan_tddi
Having looked at quite a few forums I think this isn't going to be as easy as I thought so decided to ask the garage to replace it...

Unfortunately since the EGR valve is part of the manifold, it's not that straightforward to clean/change (I think!). To add to my woe the garage have rung and told me that they can only get it through a dealer at a cost of £270!! I have rung around loads of spares places but can't find what I'm after.... Surely there are loads of Ford Focuses in sc*** yards out there??!!!!


Incidentally I've been told the part number I'm after is 1 105 928....


Anyone got any ideas????

Thanks in advance.
Ford Focus 1.6 TDDi V Reg - Flashing glow plug light and loss of power - theho

Hi

Just bought a focus 1.8 TDCi 04 with 96k on clock.

I've driven about 300miles so far - no complaints but today, the glowplug light came on and the engine cut out. On restarting - no problems since then.

Sounds exactly the same as above........did you manage to resolve this at all?

Thanks in advance

 

Value my car