Vauxhall Zafira A - 2.0 dti - Glow plug error code - PeterRed

I have been getting the car/spanner warning light when starting from cold. It stays lit for up to half a mile and then goes out. The car has also been taking longer to start. I've managed to get hold of an Op-Com diagnostics kit and the following is recorded :

Total number of fault codes: 1

P0380 - Glow Plug Circuit
(0B) - Not present

Can anyone give some pointers please before I get my spanners out? Thanks,

Vauxhall Zafira A - 2.0 dti - Glow plug error code - WellKnownSid

Hi Peter, just to let you know I've hidden your duplicate post under Motoring.

Vauxhall Zafira A - 2.0 dti - Glow plug error code - topbloke

one or more of the glow plugs is toast, gain access to the plugs pull the wires of and with a multimeter check the resistances as i said one or more will be open circuit , one word of caution they (glowplugs) sometimes snap in the head and also some tend to pull the threads out as you unwind them thats why you need to test them and realy only remove the one that is faulty, to gain access remove the metal air pipe from turbo to intercooler watch out for the rubber seal turbo end, wires are only push fit but can be a bit of a b***** to remove, enjoy Regards TB

Vauxhall Zafira A - 2.0 dti - Glow plug error code - PeterRed

Thanks. I'll have a go next week. Peter

Vauxhall Zafira A - 2.0 dti - Glow plug error code - DP

When I did this job on our old Scenic 1.9dCi, another glowplug installation known for snapping the plugs on removal, I was advised to do it with the engine warm. I did, and had no problems. It is proper heart in mouth stuff applying the initial torque to crack them loose, but take your time, and you shouldn't have any problems.

Good luck!

 

Value my car