Vivaro 03 1.9 - glowplug light on - engine running - yellowred
Hi All, Im new to this so please be patient with me!!
I have an 03 reg Vivaro 1.9 and the glow light and the light above it comes on after its been running for a while. It doesn't make the van drive badly and looks like it has no effect?? Im about to sell it so need to sort it..ANY IDEA'S would be greatfully acepted, on the basis that i cant be the first to have this?? Also in the morning the starter just "Clicks" and if im lucky it will suddenly start!! The starter at the end of its life????
Many Thanks
Dave

Edited by Dynamic Dave on 18/11/2008 at 18:40

Top Reply

03 1.9 Vivaro problem!! - crfcam

i had a problem on my 04 1.9. glow plug pops on about 2500 revs and started stuttering quite badly loss of power etc......it then started doing this all the time.....me and my friend then ivestigated this and found that the airbox which is a standard airbox was crushing and destroying the injector wiring!!! , made new connections before the plug in and now runds like a dream :) also done away with standard airbox and stuck a cone filter in its place.....keeps out the way of the wiring. hope this helps anyone witht this similar problem

All Replies

03 1.9 Vivaro problem!! - Javalin
Hiya

>Also in the morning the starter just "Clicks" and if im lucky it will suddenly start!! The starter at the end of its life????
could be that or the battery. The battery I would guess would tie in with the glow plug light?

Just guessing partly here. Anybody else want to chime in?

James
03 1.9 Vivaro problem!! - Screwloose
Dave

The glow-plug light is also the engine-management light; only getting the fault-codes read will find out what it's flagging-up.

The starter does sound a bit tired; but wiring/connexion faults can never be overlooked on a Renault.
03 1.9 Vivaro problem!! - yellowred
Ah!! yes Thanks screwloose!! Having said that i have just returned from having the van pluged in, it has an open circuit on the glow?? My last Vivaro had this and the light didnt come on!! plus "The temp sensor does not match the outside ambient air pressure" ???
HHmmm??? not much help there then??
Im gonna check the starter connections in the morning!!
Dave
03 1.9 Vivaro problem!! - Screwloose

Don't dismiss those codes so lightly - did you get the numbers?

Yes; they all use so much after-glow that glow-plug/relay faults are common - and doesn't put the light on.

An implausible relationship between the MAP and the BARO sensors is a very different matter - and will put the light on.
03 1.9 Vivaro problem!! - yellowred
Ah!! no didnt get the numbers!!!!!!
But im lost now?????? dont know what a MAP and a BARO sensor mean
03 1.9 Vivaro problem!! - Screwloose

If the code mentioned outside air pressure; then the barometric sensor was involved in the code description.

You can't get a mis-match between a temp and a pressure sensor, so I'm guessing that the implausible relationship was between the BARO sensor and the manifold pressure sensor [MAP sensor] at key-on.

Only a guess.
03 1.9 Vivaro problem!! - yellowred
Ah!! so i need to look at the manifold sensor?? or sensors?? right get the cover off then and look!!!
Thanks
03 1.9 Vivaro problem!! - Screwloose

Eyeballing them won't help; you need to be checking the readings that the ECU is receiving from them.

Wiring faults are as common as faulty components on these.
03 1.9 Vivaro problem!! - yellowred
Hi, I have finally got the code its 1001 some thing to do with air pressure??? Plus have you seen where they put the STARTER motor on these vans!!!!!!!!!! I think they built the van around it!!!!!!!
THANKS
03 1.9 Vivaro problem!! - Screwloose
Dave

No such code listed; the P1xxx codes start at P1105.

The starter may be easier on a lift. Can you get it read with a better scanner?
03 1.9 Vivaro problem!! - yellowred
well thats no supprise!! nothing this bloke does is anygood!! he did say the code 51 was up too?? My only other answer is to get Vauxhall to do it!!! i suppose.. i've tried plugging in one of these "etools" you know the kind of thing thats supposed to clear them after flashing a few times, but no good. I did speak to vauxhall and the guy in the service dept said that he thought it was a Glow plug or relay problem. But i suppose i could have been talking to anyone ???
03 1.9 Vivaro problem!! - Screwloose
Dave

These are hard to access; it may be that his tool was using the wrong protocol, so the results would be gibberish.

Vauxhall counter staff really haven't got the hang of Renault's foibles yet - have they....
03 1.9 Vivaro problem!! - topbloke
neither have renault
03 1.9 Vivaro problem!! - Screwloose

True; very true...
03 1.9 Vivaro problem!! - yellowred
Thanks
03 1.9 Vivaro problem!! - crfcam

i had a problem on my 04 1.9. glow plug pops on about 2500 revs and started stuttering quite badly loss of power etc......it then started doing this all the time.....me and my friend then ivestigated this and found that the airbox which is a standard airbox was crushing and destroying the injector wiring!!! , made new connections before the plug in and now runds like a dream :) also done away with standard airbox and stuck a cone filter in its place.....keeps out the way of the wiring. hope this helps anyone witht this similar problem

03 1.9 Vivaro problem!! - thunderbird

Completely unrelated probably since my experience was with a VW Golf. Glow plug light would come on while driving with no ill effects but a dab on the brakes would extinguish it. Would occur every 10 miles. Problem was the brake light switch. Once adjusted it was OK for a year or so, readjusted and it was OK.

 

Value my car