Boot lock faulty ? - Big Dee
I have not been able to open the Hatchback boot using the key. We have two sets of keys in our house and none of them work now.

When I try to insert the key into the lock, it's almost a struggle to push it in all the way and therefore we cannot even turn the key.

I have once managed to push the bootlid down whilst trying to turn the key and it has opened but not since.

I don't know what has happened but my thoughts are that either the lock needs lubrication (would like to know how to do this) or someone has tried to get into my boot with an instrument of some sort and something has got stuck in the lock barrel.

The boot lever from inside the car has not worked for a year or so, which is not a problem for me (yes, an inconvenience) and was happy to just use the key instead for access.

Any ideas what it could be and how to resolve this problem ?

Thanks.
Boot lock faulty ? - Dave_TD
I had a Carina E hatch for two years, it took 6 months before I realised there is a lever set into the inside of the boot to disable the remote cable release. It's in the carpet backing behind the number plate - if for example your number plate is N123ABC then feel inside the boot roughly at the back of where the the 3 and the A are - there is an unmarked metal lever which moves left and right to permit remote boot opening.

I had my (only) key snap off in the boot lock after a year of owning the car so I would advise against trying too hard to persuade it to work. I had to buy a remote central locking kit from eBay to bypass the lack of key, and also get the nice RAC man to dismantle the ignition lock.
 

Value my car