Vauxhall Cavalier Mk2 Ignition - cavvi
hi honest john, i am not mechanicly minded but do know bits about a car :-).

i went to start the car this morning,

the only thing that happened was all the ignitions lights you know battery parking light etc lit up on the dash as normal,

there was no clicking sound that you get when you turn on the ignition to start the car.

I ended up bumping it in reverse after pushing it up a hill and the car started. Came back from my journey parked up turned it off and went to start it again, the car would not start. same thing, all the usual ignition lights but no clicking sound when you turn the key, hence car wont start. what could be the problem, thankyou.

cavvi
VAUXHALL CAVALIER MK 2 IGNITION - bell boy
faulty battery?
faulty starter?
faulty ignition switch on back of steering lock?

i know of 1 cavalier that caught fire because of this switch and lots that have packed up because of the poor parts used,have you ever seen a puff of smoke come out of the cowling on starting the car? if you have then change the switch anyway,and buy the proper vauxhall one from the dealer not an aftermarket one as i now know 2 cases where these copies have caused plenty of damage to cars (both corsa"s but basically the same thing)
ok?
VAUXHALL CAVALIER MK 2 IGNITION - cavvi
Thank you, battery is fine, will check or get someone to check starter motor & i will look at the switch you mentioned on back of sterring lock. thankyou for your help regards cavvi
Vauxhall Cavalier Mk2 Ignition - HensTeeth
The wire to the starter solenoid isn't too well sealed at the starter end and the connection has a habit of corroding. If you're reasonably tall and can lean over the engine, it can be reached without removing the air cleaner (which, from memory, it's almost directly beneath). I'd try unplugging and plugging it a couple of times to clean the connection and see whether that fixes it. If so, smear some Vaseline or similar on it and it won't do it again (for a while).

Regards,

Toby
Vauxhall Cavalier Mk2 Ignition - DP
Agree with Toby. I had the same problem on my mk2. I will put money on it being the Lucar connector on the end of the solenoid wire. They're not a very good fit, and there's a hard plastic cover around the terminal that seems designed to trap crud and moisture.

You'll get it going by wiggling it, but the only way to fix it properly is to cut the connector off and crimp / solder on a new one on which fits tightly. Mine had enough slack on the wire to do this quite comfortably - just cut as close to the connector as you can. Never had any trouble afterwards.

Don't see many mk2's these days. I loved mine (1.8 SRi) - brilliant motor.
Vauxhall Cavalier Mk2 Ignition - Peter D
Agree corroded connector on Pre-engage connection of rear of starter. Regards Peter
Vauxhall Cavalier Mk2 Ignition - cavvi
Thankyou for your advice, I will try that.
Vauxhall Cavalier Mk2 Ignition - cavvi
Please dont become frustrated with me ok, i have just looked at the starter motor and there are three wires going to it. two are fixed in seperate places to the starter motor with a nut.
The and other wire i cannot see how that is fixed to the starter motor but it does have a little way along it a spade connection with some kind of rubber around it to protect the spades. I have undone this cleaned it still nothing.

Thankyou all for your advice, I will visit each area again to try and find the fault and yes the main things is I have learnt a little. Thankyou.
Vauxhall Cavalier Mk2 Ignition - cavvi
To, Oldman, Grenadier45, DP & Peter D

The car starts :-) thankyou, did the battery conections as in cleaned them. Did the wire at the starter motor must have been the right wire. Result is the car starts visit all areas that you all mentioned and the smile on my face when it started :-)

Thank you for your advice. .
Vauxhall Cavalier Mk2 Ignition - Victorbox
I'd like to add it is good to see a Cav Mk2 still doing daily duty. I can remember when they were everywhere & now you very rarely see one on the road.
Vauxhall Cavalier Mk2 Ignition - DP
Glad you got it sorted.

I had a 1986 SRi 1.8 for four years. Went like stink, great to drive, did over 30 mpg and was very solidly put together.

Just two failures in four years and 50,000 miles - a fuel pump relay and the front CV joints. I was gutted when someone drove into it and wrote it off! :o(
Vauxhall Cavalier Mk2 Ignition - SpamCan61 {P}
Maybe we can console ourselves with a model one to stick on top of our PCs ;_)

www.ehattons.com/StockDetail.aspx?SID=11870
Vauxhall Cavalier Mk2 Ignition - DP
For four quid I am actually very tempted.

Wonder if they do black four door ones? ;-)
 

Ask Honest John

Value my car