VW ECU Problems - Mr Moo
Has anybody had any problems with failure of ECUs on VAG 2.0 petrol engines? Our 2001 Beetle 2.0 (115hp) has just had a new one fitted after a one week wait to track down the only ECU in the country! Seems rather poor that such an item can fail after only 2 years/23,000 miles? Any other users with the same engine had any trouble?
VW ECU Problems - old dog
Think yourself lucky if you only waited one week to replace the alarm/interior lights/remote locking ECU on my SEAT Leon Cupra took 13 weeks! My car was only a year old at the time and I took a fairly dim view of it's failure too.
VW ECU Problems - sennapod
Yes
I had exactly the same on a 95 Golf-3 (2.0 GL) at about 35K miles

Only good side of it was the VW stumped up half the cost (about 300 quid back to me) - as I complained that an (at the time) 5 year od car, and a VW to boot!, shouldn't have these types of failure.
Probably helped that I had a full VW dealer service history - which I've since given up on.
VW ECU Problems - sennapod
I meant to go onto say that last week I noticed that on 1 or 2 occasions, when cruising at 60-ish , my speedo would drop to zero for a few seconds and then pickup again. (stall the Golf Mk3 auto already referred to)

Anybody got a view on whether I'm headed for yet another ECU failure - is this a symptom ?. I belive the speedo is electronic, and assume that the data which supplies it (ie road speed) is also fed to the ECU too for other purposes. Ideas please!
VW ECU Problems - Dude - {P}
My daughter had an ECU fail on a GTI Golf Mk 3 at only 12k miles, and the service from our local main dealer was so appalling, that she sold the vehicle in the end and took a loss of 3k in 9 months. Needless to say she will not be buying another VAG product ever again.!!
VW ECU Problems - daryld
I meant to go onto say that last week I noticed
that on 1 or 2 occasions, when cruising at 60-ish ,
my speedo would drop to zero for a few seconds and
then pickup again. (stall the Golf Mk3 auto already referred to)
Anybody got a view on whether I'm headed for yet another
ECU failure - is this a symptom ?. I belive the
speedo is electronic, and assume that the data which supplies it
(ie road speed) is also fed to the ECU too for
other purposes. Ideas please!



My Seat Arosa (aka VW Lupo, based on shortened wheelbase VW Polo) had the same 'speedo not working' failure. It was intermittent but it occurred every week. My dealer replaced the ignition switch/barrel; believe it or not the fix worked!! Blimey!
 

Value my car