95 laguna no spark - neily
anybody heard of any ignition problems with lagunas my was fine then just stopped like somebody had turned it off. there is power at the coil but it is not being switched
95 laguna no spark - Andrew Moorey (Tune-Up)
You need to check that there is a signal from the crank sensor first.Easiest way to check is see if the injectors are switching as you crank the engine? If so then it is most likely that the amplifier has failed. These are available aftermarket from Intermotor amongst others and are quite reasonably priced.
Andrew




Happiness is a T70 at full chat!
95 laguna no spark - neily
thanks andrew you were right, it is the amplfier.
95 laguna no spark - neiln
exactly the same happened to my car last week, it just stopped,
replaced the crankshaft sensor like the AA man told me, still nothing,
how do i check to see if the injectors are switching as i crank the engine ?????
i'm gonna get an amplifier in the morning regardless,
thanks,
neil
95 laguna no spark - Andrew Moorey (Tune-Up)
You need an assistant to help you here. Whizz the plugs out. Get a long thin screwdriver and place the end of the screwdriver onto an injector. Place the handle against your ear and have your assistant crank the engine. You are listening for a sound like a watch ticking. If you can then amp is most likely. If not then you will need professional help, DON'T just start throwing money at it. You may have some redress against the AA for misdiagnosis but I may be wrong.
Andrew



Happiness is a T70 at full chat!
95 laguna no spark - neiln
hi,
no luck,
fitted the new amplifier and still nothing,
could it be the coil????

it's a single point injection and i listened to what i thought was the injector and heard the ticking,

many thanks
neil
95 laguna no spark - Andrew Moorey (Tune-Up)
Possibly the coil but most favourite option will be the crank sensor on the top of the clutch bellhousing. With the single point system you can actually see the fuel being injected onto the throttle butterfly if you remove the intake from the TBi unit. If no fuel suspect crank sensor but we are now getting into the realms of a proper methodical diagnosis.



Happiness is a T70 at full chat!
95 laguna no spark - neiln
hi,
thanks for your reply,
first thing i replaced was the crankshaft sensor,
no luck,
you then mentioned it may be the amplifier module,
i replaced it (motorolla module),
no luck,
when i try and start it, if i pump the throttle i can smell petrol,
i was gonna try the coil next,
but, bearing in mind you said not to throw much more into it until i had it properly checked out i was a bit reluctant,
will check tomorrow night and see if i can see the fuel being pumped into the carb,
many thanks
neil

ps. i opened up the ecu, there's 2 relays, one looks like it's had the wires cut and taped up, three of them,
they are 2 yellow and (i think) a green one, looks a bit suspicious, could the AA man have had a fiddle or should they be like this????
neil
 

Value my car