Nissan Almera Tino 05 - Centre Console+Centre Control NOT working ..FIXED - DaveM1965

PROBLEM:

So there I was driving along listening to my CD when the CD Player and Centre Display which shows the time, radio, Blowers etc when off....

The only life I can get from the Control Panel which is the middle of the two is the rear heater ... all other controls are dead... and the CD player wont eject the disk...

The heater is stuck on hot blowing and the only way to turn it off is to take the fuses out

I got an expert car electrical guy out and he say the units all have power going to them.

So I assumed it was all to do with the main display or to give it the correct part name: DISPLAY ASSY-AV so off to EBay I went and bought another one....installed it today and still nothing... Having replaced all three units now its still dead :(

FIX:

Took it to the dealership and they found that the units only had 5 volts going to them.

They stripped back the wiring loom and found two broken wires in the engine bay loom. They soldered in new lengths of wires, insulted them and tested them and now its all working!

Hope this helps someone :)

Nissan Almera Tino 05 - Centre Console+Centre Control NOT working ..FIXED - bathtub tom

>> They soldered in new lengths of wires, insulted them

I'm often found swearing at mine as well!

;>)

ps. I know what you meant.

Nissan Almera Tino 05 - Centre Console+Centre Control NOT working ..FIXED - steve2017
Bit of a long shot as this is quite an old thread.
But I have exactly the same problem on a 2004 nissan Tino.
Only button that seems to have power to it is heated rear window.
Have tried new units and still the same.
Do you have any more info on where the wiring issue was at all?
And how it was found? Thanks
 

Ask Honest John

Value my car