Peugeot 406 hdi estate 'X' 2000 (air con) - Heater fan not working - Ralph Edward Burton

Heater fan stopped working. Read several forums. Replaced control module/resistor, checked fan works with a direct supply. Power to fan but fan still will not work when all connected up.

The small wires that go into the control module only show 5v no matter what the fan speed is set at on the dash control.

Any wizz kids out there got any ideas?

Peugeot 406 hdi estate 'X' 2000 (air con) - Heater fan not working - elekie&a/c doctor

If I recall,the speed regulator is on the earth circuit from the motor.So it is important that there is a good earth/ground from the speed controller to chassis ground..Possibly a black or green/yellow wire.Also,you say there is power to the motor,but have you load tested this power supply?A flakey power to the motor will not let it operate correctly.

Peugeot 406 hdi estate 'X' 2000 (air con) - Heater fan not working - Ralph Edward Burton

With all wiring connected, if I run a separate wire from the negative at the motor to chassis, the motor will run full speed. If I run from the negative out of the control module the motor will not run at all. (I understand that the negative runs through the module.)

Will checkearths as soon as I can.

The whole system was working fine until I got in the car two days ago. Started it up and no fan.

Peugeot 406 hdi estate 'X' 2000 (air con) - Heater fan not working - Ralph Edward Burton

Additional question.

What should the voltage be at the two small wires going into the control module for the various fan speed settings? Either wire to earth or wire to wire. This may help.

 

Ask Honest John

Value my car