Vauxhall Astra 1.6 SXI - Engine light on and flashing  
Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

My son's Astra 1.6 SXI 52 plate has its amber engine light come on and then flashes and goes into limp mode, easy fix you would think. Firstly we had the car in a garage and ecu fault codes checked, came up with coil pack, I replaced that but no difference found, booked it into Vauxhall main dealer garage and they diagnosed the coil pack.

They replaced the coil pack and plugs suprise suprise still the same,they then said it was the ECU so they tried that, Oh oops still the same,next came the big suprise sorry we're stumped so there we are still stuck only saving grace is he's only had to pay for 2 diagnostic's, the car is back on its origonal coil pack.

What I've found is if you disconnect the battery for a period of time and reconnect the light will be off, go for a drive its fine but after a mile or two the light will come on then it will start to flash and your in limp home mode it also sounds like its miss firing at idle,disconnect and reconnect the battery it will idle fine but the light will be on but not flashing. Vauxhalls tell us the only fault code is coil pack and all the sensors etc are ok.

Anyone else had a similar problem and over come it

Cheers.

Tags: technical issues electrical faults batteries DPF

Vauxhall Astra 1.6 SXI - Engine light on and flashing - clewsy01
Hi, I know how you feel, and you feel like banging your head against a brick wall. and I have a Zafira with a Z16XE engine, and have made some posts about issues simular to mine.

On mine i replaced the coil pack, cleaned plugs, cleaned egr, disconected battery, tried some new plugs and eventually it had to go to VX for a full tech on the computer.

It came baxck with

Low fuel level misfire
cyl 1 missfire
multiple cylinder misfire
egr sensor curcuit.

The result, a clear of all codes stored and a new ecu software. Advised that if it does it again to change the EGR valve as it could the the EGR values messing up the running causing misifres.

Have you got a printout from the diagnostic from VX, they should give you one its what you paid for as you will see exactly what the ECU. is telling it. Have you tried the spark plugs? EGR, take them off and clean them. If your plugs are balck then its overfueling like mine and you may find that will be the root of the problem.

Vauxhgall also advised me to keep my fuel level above the quarter line as running it with low fuel caused one misfire acording to the diag.

Anyway got may car back today, best its drove for 2 weeks, not goning to count my chickens and says its a full fix but time will tell.
Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

No we don't have the print out,basically when it first came on I gave it a service including new plugs fuel filter etc etc,the old plugs were a perfect biscuit colour as that didn't cure it we put into a local garage just for a fault code this showed coil pack so I changed that (non genuine) but that didn't work.

We then put it into the local Vauxhall main agent who came up with coil pack and still they say the only code is coil pack, they fitted a new coil pack and new plugs, no difference so they got the ECU code and replaced the ECU still no difference and now say they're stumped apprently they had there top technician on it. I don't know if this model has an egr valve as I cannot see a link from the exhaust to and egr valve.

Glad you seem to be sorted

Vauxhall Astra 1.6 SXI - Engine light on and flashing - clewsy01

it will have an egr. you need to post your engine code. depending on year it may be z16xe or x16xe or maybe a newer version and its under the cover and looks like a little canister a few inches for the coil pack wiring.

michael

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

Do you mean the ECU code ? We don't have that unless we pay the main dealer £25 for it they had to get it to change the ECU. The engine number on the log book is 20AA5337, I'll have a look at the EGR valve tomorrow.

Cheers

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Railroad.

Just because the fault code says coil pack doesn't mean it actually is the coil pack at fault. A coil consists of a set of primary and secondary windings, and the system either uses either one coil per cylinder, or one per pair of cylinders depending on the type of system fitted. The individual coils are built together as a pack. The ECU does not monitor the secondary windings, but it will log a fault saying coil pack if a primary winding circuit is either open or short, wherever that fault actually happens to be. The coil is switched by the ignition module which is an integral part of the ECU, and so it's worth checking to see if it's switching on the cylinders that are misfiring. If it isn't then it's most likely the coil is not at fault, and that you have a break in a wire between the ECU and coil or a fault in the ECU itself.....

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

Cheers I'll look into the wiring between the ECU and coil pack,as the Vauxhall dealer fitted a new coil pack and ECU to try and that made no difference I can assume that they aren't the problem.

I've found out through auto data this model (I believe with a Z16XE engine) had a problem with a miss fire and poor idling due to a problem with the temp sensor and loom, as this is a cheap item I've ordered the modified sensor and loom, why the main dealer didn't try this I don't know.

Also I've found that when the light comes on its only number 4 cyl cutting out (its the only plug very wet when removed) this ties in nicely with an open circuit,I did a hot compression check on all cylinders and there all around 190psi. I'm wondering if the EGR valve could be the fault as it located on the manifold right next to number 4 cyl.

When the light is off it runs fine and all plugs are dry when removed.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elekie&a/c doctor

May be a good idea to buy yourself an egr blank-off gasket from vauxhall for around £3 as a trial to your theory.hth

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

I'll look into that didn't know they did a blank off gasket infact I could easily make one.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

Well Vauxhall don't do an EGR blank off gasket for the 16v engine only the 8v engine.I've checked out all the coil pack wiring to the ECU and the continuity all checked out, in desperation I disconnected both oxygen sensors to try, this has made a difference the light doesn't come on so early or flash so often, I'm still going to fit the modified temp sensor and loom when it arrives and I still have my doubts regarding the EGR valve.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - priceymike

Hi, i'm having same problem. Hope your having more luck than me.

Although i believe the fault code i've had P1600, means ecu failure.

Did you get a quote for a new ecu? And how much did vaux charge?

With regards to egr, have you tried unpluging and then see how it runs.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Collos25

Typical symptons of a faulty EGR.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

The Vauxhall dealer had a good ECU that they use for testing they got the code for my son's ECU, programmed it and tried it,that didn't work either.

We didn't get a quote for the ECU.

I think the dealer was embarassed about it because in the end they just charged £45 for the fault interigation.

I've tried disconnecting the EGR but it just stalls the motor.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Collos25

I do not think it should do that.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

I agree, something else I've got to look into.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

Fitted the new temp sender and loom, so far so good on the first 16 mile road test.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - priceymike

Thats good news, fingers crossed its ok now.

I'm sending my ecu away for testing. If a fault with temp circuit i know where to look.

Do you have a price for the temp sender and loom?

Vauxhall Astra 1.6 SXI - Engine light on and flashing - clewsy01

Good to hear that the temp sensor and loom has worked so far. Do you have a link or the place you got it from, as mine has again started misifiring!, Mine seems to like doing it when the weathers cold!. was it easy to fit as well?

Well done anyways good to hear a good outcome so far, as sometimes people dont come back and tell us the results on here.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

Well its bad news it came back on its just taking a hell of alot longer to do that than it did before, I've ordered an EGR valve now, found a new one on ebay cheap.

I'm also getting a code reader that covers most cars, makes sense as thay cost about the same as going to a dealer to have it done.

The switch was a straight swop the loom is just spliced into the old one under the cover above the injectors, I made up a proper plug instead of joiners.

The switch and loom was £19.33

Edited by elsinore167 on 01/12/2010 at 16:43

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Enginostics

Hi, just a quick read of the issues related to the problems you are having with your vehicle. We are fuel injection specialist with a BEng in electronics and mechanical engineering with years of experience in the motor sports industry and I have to say, more than 50% of vehicles we work on are Vauxhalls. I'll give you a run down on what you need to be looking at:

1) The ECU is mounted in the engine bay. It's a very harsh environment for a control system to be fitted. There is also various frequency of vibrations acting on the ECU. We have come across ECU's failing due to these factors. The ECT circuit and idle system circuit is common to fail in the ECU.

2) The EGR control system on Vauxhalls is prone for problems. Best thing to do is to install a blanking plate and have Vauxhall to reflash the ECU to eliminate EGR control software.

3) Check and clean the throttle body. Check for any vacuum leaks around the intake side. Carbon deposits around the butterfly valve is known to cause problems.

4) EVAP purge valve can cause this problem too.

You need to have the vehicle plugged into a good diagnostics scanner and the live data read by a competent person who knows what they are looking for.

Next step would be to check the wiring loom for damage and all plugs and connectors checked.

The list is endless but don't forget.....anything is fixable by the right person.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - elsinore167

Thanks for all that its very helpfull, as you may of read the car was dealt with by our local Vauxhall main agent and they gave up on it !!!!! They said they fitted another ECU and Coil pack and that failed to cure it.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - mbryant

Sounds identical to the problem I'm having with my 2001 Astra. As soon as the cold weather starts the engine will start miss firing, juddery to drive, eml light on and flashing. Last year a mechanic replaced the coil pack and plugs which fixed it temporarily but the problem came back. Took it to the Vauxhaul dealer and they had the car for about two months. Eventually they sent the ECU off the be tested but it was not that. After the ECU came back the car started running ok again and they did not admit to know what the problem was. A couple of weeks ago the same problem has come back. Really don't know what to do now other than sell it for next to nothing and have to buy a new car.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - clewsy01

Well after my problems with exactly the same symptoms and engine, but in a 1.6 zafira, I had the codes cleared and fitted myself a new coil pack and egr valve, it came back a few days later and then i decided as a last measure to fill that tank with shell ultra, the one which cleans your engine and after about 5 miles.... whoosh, back to life purring like a good one, I have since filled the tank again and now added the redex injector cleaner as well and its now runs ok, even with our latest cold snap here.

what i have learned from my problems is. check a plug and its colour see if its overfueling. see if it mis fires constantly or just with a low tank, vauxhall told me that sometimes the ecu can switch off an injector if its faulty, dirty, or to save fuel, dont know if thats true but I did get fault codes of misfire cylinder one, low fuel level.

I know how you feel, as it drives like a pig, and your very weary to go anywhere. my next step would have been to look at the coolant temp sensor as again vauxhall told me (although again is it true?) that the ecu uses some values of the coolant temp sensor to adjust the fuel feed to ensure good running in different temps.

might sound simple or daft but give it some good fuel and some redex with a new fuel filter and see how it goes, must be worth a shot if nothing else works.

hth michael

Vauxhall Astra 1.6 SXI - Engine light on and flashing - mbryant

Thanks for the advice, I'll give the Shell petrol a go. Just got the car back from another mechanic who did some basic testing. He is adamant that the coil pack needs replacing as the engine is misfiring on one cylinder, even though the Vauxhall service centre tried that and it made no difference (plus the one I have is only about a year old). Maybe I'll have to give it a go but I think it might just be another £90 wasted,

Everyone I have spoken too, I have suggested blanking the EGR valve but no one thinks that is the problem. I'll probably give it a go though as it looks fairly simple to do. I think I'll try replacing the coolant temperature sensor too as it could be giving bad data to the ECU. Not that I'm mechanically minded but no one else seems to be interested in trying this.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - clewsy01
whats you engine code, If you have a Z16XE, Z14XE, X14XE, or X16XE i would not reccomend blanking it off as it can run lumpy. easy to do the the 8valve as the blank it and re-write the ecu software so its runs without it. If its blanked it may run worse with out an ecu update so could cost more than replacing it, but speak to vauxhall to make sure.

Best option is to try a new egr valve vauxhall one, you can get one off here www.vauxcentre.co.uk/ they are who i use for my vauxhall parts. You will also get better prices for a coil pack on there.

Does the mechanic say which cylindr is misfiring and whats the code he gets, it should be along the lines on P0301 that may help.

hth michael
Vauxhall Astra 1.6 SXI - Engine light on and flashing - mbryant

It's a Z16XE. I think he said it was cylinder 3 that was misfiring but I did not think to ask to get the codes. He did say that it was reporting codes for the coil pack and EGR.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - clewsy01

if its pot 3 it will be p0303 code then. misfire cylinder 3 TBH i would swap the EGR as it might not be working correctly. EGR very common on these that they go after a while and if it works it is like driving a different car.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - mbryant

ok, I'll look to get a new one. I'll try the petrol trick first to see if that makes any difference (if I can find a Shell near me, they all seem to be BP! ).

Vauxhall Astra 1.6 SXI - Engine light on and flashing - clewsy01

im sure the bp eqiviulent will be just as good if they do one. give it a fill and a little bit of a itallian tune up for a few miles and see how it goes. obviously if it starts to misfire and limps dont hammer it as it could knack the cat.

good luck

Vauxhall Astra 1.6 SXI - Engine light on and flashing - zoe c

hi all

I have been having the same problems for some time now and my car is on it's 4th coil pack - to say I'm p***ed off is putting it mildly. The first occured around 18 months ago and I took it back to the Vauxhall garage where I had been having it serviced. they diagnosed the coil pack and fitting another one to the cost of £150.00. Problem solved - but then 6 months later in Jan 2010 my engine management light came on and I called out the RAC who duly diagnosed the coil pack after a diagnostic but noted that the spark plugs had caused it to pack up as the Vauxhall dealer had fitted a new coil pack with old spark plugs (the ones that actually came with the car - they had not been changed in 5 services and 90,000 miles)

New coil pack - new sparks - everything OK till yesterday - less than a year after the 3rd coil pack the engine light came on again - RAC did another diagnostic and pronounced the coil pack but noted that something inherently wrong in the car was making them go (they did have singeing on the prongs) . They replaced the coil pack but warned this would not be the last of it and I know they're right. I have spent too much on this car already and I just want someone to fix the real issue but no one seems to know what it is - help - I cannot keep going on with such an unreliable expensive car!

It's a 1.4 Astra SXI 56 plate

Vauxhall Astra 1.6 SXI - Engine light on and flashing - mbryant

Just to give an update to my last postings. I bought a second hand coilpack (Delphi) from ebay for £30 and a new set of spark plugs (Boch Super 4's - don't know if they make any difference but they look high-tech). Fitted them both today and the car is now running a lot better than it has for a long time.

I didn't think this would work as with the exact problem last year it was in the Vauxhaull dealer for several months and they said the first thing they changed was the coil pack and it didn't fix it. So I really don't know what happened there.

At least fitting this part yourself is very easy. It's just 4 bolts and unplug the connection.

There does seem to be an underlying problem though with these coil packs failing after a short time. This is my second after about 13 months.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - sniper1966
Vauxhall Astra 1.6 SXI - Engine light on and flashing - LeeSmith

I have got the same car Vauxhall Astra 1.6 SXI with same problem started yesterday. After reading the threads here, I have just bought a coil pack and will look to fit it tonight.

I have no idea what I am doing, but will have a look and see what I can work out. If any one has any tips or instructions I would be most grateful. Best tip may be to leave it for a garage to do, but I am really struggling for money. If it looks too complex I will have no choice but to leave it.

The coil pack I bought was just under £70. Is this too much as I see cheaper ones been bought from e-bay as per last thread. I just would not be sure if it was the right one, plus am at work often so never get chance to get any big post.

I am thinking it may be best to get new spark plugs as well?

Regards

Lee Smith

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Hartsie167

Hi there, I have a similar problem with my astra (51 reg 1.6 16v). Had the code back as P0325 knock sensor. The symptoms are baffling, engine is quiet, runs perfect until I hit 2500-3500rpm then there is no more power pedal to the floor and the highest it goes is 3500rpm. Engine management light (car with a spanner) comes on, car still drives through all gears just doesn't go over 3500rpm. I've tried new coil pack, no change. New sparks (bosche plus ones), no change. New oil filter and oil, no change. Checked lambda sensor for a new one, no change. But a real puzzler is that I found oil in the connectors on the ECU, cleaned them off and still no change. How does oil get in there? Anybody have any suggestions as to what the problem could be for the loss of power at 3500rpm with electrical fault code P0325 Knock sensor?

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Rolandas

Hi everyone. I owe Astra G sxi 1.6 16v reg plate 51.

I had an error code, that indicated that EGR was faulty, checking it with multimeter and confirming incorrect readings, I've changed EGR and error was gone.

But now I get p0440 absolutely randomly. I can drive 30 miles without it one time, but sometimes it lights up every few miles. As soon as engine light goes on, car goes into limp mode. I have OBD2 Bluetooth reader and Torque on android so I just clear the error and everything goes to normal. However, this problem became really unstable, sometimes as soon as error is cleared it comes back straight away. I've cleaned throttle body recently and it helped somewhat, get more power than not in limp mode. Worth mentioning that engine never warms up (always at starting location on the dash). I was doing only short trips before, so haven't worried about it until I did 100miles drive with temperature gauge at below 80 (?) position (in same position then ignition is off).

I have plenty of tools (do most of the stuff on my bike by myself) just need guidance where and what to check on this car. Thank you so much!

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Rolandas

Problem resolved by changing ECU. I had p0440, p1120, p1122, p1550 all making car go into limp mode, after replacing ecu all mentioned errors disappeared and car drives great.

But now I have fallowing errors p1481, p1482, p1483, p0530. This something to do with cooling fan and AC. Is it save to drive with these? I tried to warm engine for fan to kick in, but it's too cold outside got to 92 max and after starting driving went down to 88. There were no such a faults on old ECU and fan would kick in around 98 if I remember correctly.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - peterh1

I have an 54 plate 1.6sxi 16v which has developed the same issue after a Battrey Change. The old Battrey died and i bought a new Bosh. Started the car fine and within 6 miles the EML came on and i went into limp mode. As the weather has been -7.5. I suspect the Coil pack but after reading the threads it looks like i may be wrong. Should i start with EGR valve? any sugestions would be a help.

Many Thanks

Peter

Vauxhall Astra 1.6 SXI - Engine light on and flashing - curtis

i have a y reg astra 1.6 sxi 79.000 on the clock and have had the same sort of problem as soon as the car reaches 80 degrees on the temp when i am driving and let the revs drop below 2000 revs the engine just cuts out then if i resart it when driving its starts to kangaroo i have the code its p0400 which indicates the egr valve i hope its wright yet to have one fitted will let u know also some times the temp gage doesnt go up will have that done aswell

Vauxhall Astra 1.6 SXI - Engine light on and flashing - yiddz

hi have exact same problem. did you find what it was? read that you can blank off egr valve but not sure if thats a good idea?

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Brizospark

Has anyone managed to find the root cause of the problem with this one?

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Nicole93

I have a Vauxhall Astra SXI 16v twincam 03 plate. I am having the exact same thing happen, i hav changed coil pack and sparkplugs. When i bought the car the bloke told me it was a great car, well he lied. With in a month the enginge light came on, we managed to get it off by disconnecting the battery like you did. It only got worse. The car is now constantly miss firing and engine light will stay on and flash in limp ome mode, even if battery was disconnected over night. I have oil going through like no tomorrow which is running through neat and spluttering out the exhuast, it and fuel is now a problem aswell the injector is blocking, i have tried injector clearner a few times but no luck? Back to the main problem, i have continued to drive the car as being young cant afford to fix this and insurance! The car is nearly giving up, it is running on 3 cylinders instead of 4, which makes even pulling away difficult let alone getting up to speed. The only thing i have been reccommended is an engine change, does anyone know any other solution other than this!? Any help atall well be a great :)

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Tex0904

Hi Everyone,

I Have an Astra 55reg 1.6 sxi my engine management light has come on . When iam driving my engine cuts out and would not allow me to start the engine but after 10-15 seconds when i turn the key the engine switches back on drives as normal but after a bit engine cuts out again. I have been to few electricians they say its recognising 13 faults but they are not 100 % they are all maybe faulty but they say it might be an ECU

CAN SOMEBODY PLEASE HELP THANKS !!

Vauxhall Astra 1.6 SXI - Engine light on and flashing - muzzy225

hi. i'm having same problem with my zafira. did you manage to get your astra sorted. regards chris

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Debbiedoo

I have had the same problems as everyone else and had the coil changed twice and the light still went on after 5 minutes of driving. I topped up with some different oil and what a difference it made, i think i was using oil for a newer car and that seemed to be the problem. I would say for about 5-6 months it has been great but now the problem is back so back to square one. :(

Vauxhall Astra 1.6 SXI - Engine light on and flashing - simonmonty

Hello Debbiedoo.
I tried using redex fule cleaning flush and expencive petrol as sujested on this forum it worked for about 6 months then the problem came back again. Ive tried using redex petol cleaning again but has made no diference.
I have a friend who is a machanic and he has no idea what the problem is and has changed everything that he can. He said there is no fault code for the problem so cannot fix it. The only thing he sujested was to replace the engine it self as there was no other solution he could think of.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - totrustworthy

same problems here 1.6 55 plate sxi

took to a garage( friends) management light on did the test came up coil pack plugs etc changed those drove fine for 50 miles then went lumpy pulled over turned engine off for 1 mins turned back on car drove fine again same thing did 300 miles with this happning 3 or 4 times .

took this back to garage today thay said checked codes again now saying low fuel ????code 10300 im sure he said may have that wrong ??? but i think my garage are a biit stuck plesae please help sombody

do you think i take it to md and tell them its not coil pack and plugs or what im so gutted

if anybody can help im willing to pay for there time

Vauxhall Astra 1.6 SXI - Engine light on and flashing - simonmonty

I think I have sorted the problem It seems to be a fue starvation problem its getting clogged up some where in the fuel line system .
I just put a full bottle of redex engine fuel system clean in the fuel tank and took my car for a long drive up a motorway and gave it a good blast down it as sugested by a friend who is a macanic and its worked. runs perfectly now .
No more engine managment flashing light or miss firing or cutting out.
My friend said some engines are just not made for running about on shot distances around towns they need a good run out on the motorways now and then to keep the fuel system clean.

Vauxhall Astra 1.6 SXI - Engine light on and flashing - CookieG

Hi, Astra Mk4 02 Plate (160 miles!!) Ok so my beast sits idle for about 2 mins then just cuts out? Friends suggested fuel starvation? I do have Mass Air flow sensor code flashing up on obd2 reader. Would this cause the car to cut out? I have read everywhere about coils, sparks and EGR etc plus cleaning throttle body - done all those bar EGR. It get warm then cuts out so any root cause? I read changing crank shaft sensor is a possible fix. Thing is, should I keep ploughing mucho money on the problem or just get rid?? lol - Any suggestions welcome!

Vauxhall Astra 1.6 SXI - Engine light on and flashing - Rolandas

Can you start the car after that or you need to wait for engine to cool down?

Mine has problem in ECU, then engine gets warm ecu disconnects fuel pump. You can troubleshoot this by removing fuel relay under the hood and short-circuiting two contacts. This will make fuel pump always run no matter what (even with ignition off, so this is just for ruling out fuel pump issue)

Vauxhall Astra 1.6 SXI - Engine light on and flashing - carlton driver

Had a nightmare trying to reduce the CO emissions on my brothers astra x16 szr .

missfires, black plugs, coil pack fault codes,but seemed to be running fine ,

tested everything i could think of, replaced inlet gaskets,oil 15W40 mineral (not synthetic) ,breathers ,vacuume pipes,tested map,cts,egr, sensors,RESET ECU, live data on solus reader (NOTE you can not use obd2 elm327 on some mark 4 astras) ,ecu reporting everything is ok readings wise

found the injector was over fueling badly, not reported to ecu !

fortunately i have another brother with the same astra so could swap parts from one to the other to diagnose what was going on .

it had been to 3 diffrent garages ,who miss diagnosed it before i got my spanners on it , all said replace the cat .... er NO ! find the over fueling problem before you even think about sticking a cat on, (because anti freeze and overfueling can contaminate your cat and render it useless)

explains miss fires and coil pack failures,intermittant MIL lamps etc

Vauxhall Astra 1.6 SXI - Engine light on and flashing - crazylegs02

October 2012 ,at first it cut out 10 mins after buying it , rang the fellow i bought it off he said "has the service light come on " a day after buying it off Goldie a mechanic in Earlestown lol mechanic my @%^# , so he did service and got codes off . then . two days later it came on again and 4 miles on cut out on the motorway took it back he had the car two days and changed the cam sensor twice but it still showed up cam sensor . he said " I can't figure it out " and give me the keys and said i'll have a look on internet and get back to you so me , I drove it home very time it cut out i'd switch engine off and turn igition to ON and bump it while still in motion that went on for 2 mths i had to i was working and needed it . Anyway he hadn't got back to me so i went down he said " give me address i'll come for it Saturday morning " he never showed , so i took it to another mechanic and he said changel the cam and crankshaft sensors ,egr valve and the thermostat .... so i did had the ecu reset and ....... still the same took it off the rd in october finally as i could now not afford to tax and insure it as i lost my job for always being late , i couldn't afford to get another car , so i decided take it off the rd save up and have a proper mechanic get it running get an MOT and get shut part ex or somat , i have had it with a mechanic now for three days and he's changed the lamber sensor the cam sensor and egr valve again as he said they are faulty that i put on ........ 250 quid later and its still the blooming same .................... has anyone got a clue .... he's now saying its the inlet manifold and the throttle body ?????

Vauxhall Astra 1.6 SXI - Engine light on and flashing - crazylegs02

October 2012 ,at first it cut out 10 mins after buying it , rang the fellow i bought it off he said "has the service light come on " a day after buying it off Goldie a mechanic in Earlestown lol mechanic my @%^# , so he did service and got codes off . then . two days later it came on again and 4 miles on cut out on the motorway took it back he had the car two days and changed the cam sensor twice but it still showed up cam sensor . he said " I can't figure it out " and give me the keys and said i'll have a look on internet and get back to you so me , I drove it home very time it cut out i'd switch engine off and turn igition to ON and bump it while still in motion that went on for 2 mths i had to i was working and needed it . Anyway he hadn't got back to me so i went down he said " give me address i'll come for it Saturday morning " he never showed , so i took it to another mechanic and he said changel the cam and crankshaft sensors ,egr valve and the thermostat .... so i did had the ecu reset and ....... still the same took it off the rd in october finally as i could now not afford to tax and insure it as i lost my job for always being late , i couldn't afford to get another car , so i decided take it off the rd save up and have a proper mechanic get it running get an MOT and get shut part ex or somat , i have had it with a mechanic now for three days and he's changed the lamber sensor the cam sensor and egr valve again as he said they are faulty that i put on ........ 250 quid later and its still the blooming same .................... has anyone got a clue .... he's now saying its the inlet manifold and the throttle body ?????

Join the discussion

Buying Advice

Honest John's Newsletter

Connect with Honest John

Facebook YouTube