Quantcast
Let us know what life is like with YOUR CAR And you could win one of three ipads | No thanks
04 1.6 Loss of power when travelling at ~70mph - bif101
I have a vauxhall zafira 1.6 petrol 2004. After about 10 minutes on the motorway doing 70-75 mph, the car looses power and the car/spanner icon appears on the dashboard. I'm assuming the car is going into some type of 'limp home mode' because if I then keep the revs below 3000 rpm you can't tell there is a problem (although the dashboard icon stays lit up) When I then stop and then restart the engine, the fault icon has reset itself.

Any ideas as to what is causing the fault and also will the fault be recorded in the ECU if the dashboard icon is no longer lit.

i don't really want to take it to a garage and be charged for them to interrogate the ECU if nothing is going to show up as a fault

Thanks

Tags: technical issues engine problem electrical faults limp mode

04 1.6 Loss of power when travelling at ~70mph - Dynamic Dave
will the fault be recorded in the ECU if the dashboard icon is no longer lit.


It should be, providing the light has been on for longer that approx 30 seconds. However, any stored fault codes generally get deleted after 'x' days or 30 or so clean start ups. By that, I mean 30 or so turns of the ignition key where no more faults occur.
 

Value my car

Amount to borrow
Sorry. The minimum loan amount is £1000
To pay back over

My credit score

Best available rate 9.20%

Total repayment £9,304.93

Total cost of credit £1,804.93

£155.08

60 monthly payments

Apply now

Representative example

The Representative APR is 13.2% (fixed) so if you borrow £7,500 over 4 years at a rate of 13.2% p.a (fixed) you will repay £199.21 per month and repay £9562.20 in total.

;